From: David Vallner Date: 2006-02-10T22:27:47+09:00 Subject: Re: Yahoo! Widgets (JavaScript) - do we have a anything like this? Dňa Piatok 10 Február 2006 12:44 Mark Somerville napísal: > On Friday 10 February 2006 10:04, Mark Somerville wrote: > > On Friday 10 February 2006 01:52, David Vallner wrote: > > > Hmm, how "rubyish" are the Qt and GTK bindings anyway? I have > > > personally a HUGE pet peeve against ever writing using for example > > > #set_foo in a ruby binding instead of #foo= (wxRuby); > > > > That particular thing is solved for Qt4 - > > http://www.kdedevelopers.org/node/1686 > > > > > goes for camelCase in method names, or > > > Hungarian notation in class names instead of using module namespaces > > > (FOX). Even if there's probably very good reasons for both of those, > > > and if not, possibly very unreasonable to change them now, my mind > > > still has problems switching between naming conventions mid-script. > > > > But the camelCase is still there. > > I think I was wrong. I haven't tried it out, but the README from the latest > release (and perhaps earlier, not sure) suggests that you can use > underscores or camelCase. > > Cool. Utterly. It seems there's more people around with pet peeves like me. (Run for the hills! Doom is upon us!) David Vallner