From: Mark Somerville Date: 2006-02-10T20:44:06+09:00 Subject: Re: Yahoo! Widgets (JavaScript) - do we have a anything like this? On Friday 10 February 2006 10:04, Mark Somerville wrote: > On Friday 10 February 2006 01:52, David Vallner wrote: > > Dňa Piatok 10 Február 2006 00:34 tsumeruby@tsumelabs.com napísal: > > > Well, I'll reply in the middle of the paragraph. I usually think about > > > ruby bindings; how much they are complete and are they stable the > > > bindings are compared to others. Qt might be the best toolkit to use, > > > however the ruby bindings are not frozen yet, hence I don't want to use > > > it until rdale stops modifying how the toolkit works. He just made the > > > signal/slots similar to how rails works. GTK is very stable and one of > > > the two top best at stability. Tk is the most stable of course, being > > > around longer since all of the other toolkits, and now in 1.8.4 having > > > the method to switch all the tk methods to use tile so the developer > > > doesn't have to call on tile widgets. FOX is okay, but when you don't > > > call methods right, you end up with crappy code because you can't find > > > which method you called wrong when you have a 5000 line script. I don't > > > write line by line, execute as I type each out like a new programmer, I > > > write half complete programs before I start testing. > > > > Hmm, how "rubyish" are the Qt and GTK bindings anyway? I have personally > > a HUGE pet peeve against ever writing using for example #set_foo in a > > ruby binding instead of #foo= (wxRuby); > > That particular thing is solved for Qt4 - > http://www.kdedevelopers.org/node/1686 > > > goes for camelCase in method names, or > > Hungarian notation in class names instead of using module namespaces > > (FOX). Even if there's probably very good reasons for both of those, and > > if not, possibly very unreasonable to change them now, my mind still has > > problems switching between naming conventions mid-script. > > But the camelCase is still there. I think I was wrong. I haven't tried it out, but the README from the latest release (and perhaps earlier, not sure) suggests that you can use underscores or camelCase. Cool. Mark > > Mark > > > David Vallner