From: Kevin Olbrich Date: 2006-01-24T03:49:05+09:00 Subject: Re: Hungarian Case variable names. James Britt wrote: > Mark Probert wrote: >> much more readable. Verbosity can be a real impediment to readability. >> > > Well, readability and communication are key. > > James An interesting concept for functional apps (or system) Hungarian in Ruby. It would be pretty easy to set up the missing_method function to extract out certain tags from a variable name. For example, assume you have a model with an attribute called 'Text' you could set up missing_method to pick up 'iText' and return 'Text.to_i' or 'hText' could return 'h(Text)' etc... NOTE: I'm not advocating that this is a good idea, I'm just pointing out that you could use Hungarian notation in Ruby and actually have it do something. _Kevin -- Posted via http://www.ruby-forum.com/.