From: Jacob Fugal Date: 2006-01-05T02:01:01+09:00 Subject: Re: Email Address Regex [was Re: silly regex question] On 1/4/06, Tim Fletcher wrote: > http://tfletcher.com/lib/rfc822.rb > > (doesn't look quite as messy :) Yeah, as I said in the footnote, the regex I posted needed some readability treatment. Yours looks pretty nice, and exactly equivalent except for a typo in quoted_pair: - quoted_pair = '\\x5c\\x00-\\x7f' + quoted_pair = '\\x5c[\\x00-\\x7f]' Jacob Fugal