From: Bill Guindon Date: 2005-12-08T23:29:46+09:00 Subject: Re: They say I write Ruby like Perl On 12/8/05, Chris Game wrote: > Ryan Leavengood wrote: > > > 1. The general naming convention is lowercase with underscores for > > variables and methods. You have sort of a mix of > > "runitalltogether" variables, i.e. prevsibling, and then the > > CamelCase methods like insertSiblingAfterYou. Those should be > > prev_sibling and insert_sibling_after_you (though that last one > > is a bit too long.) > > Who says? Just a style/convention issue surely. Readability doesn't > suffer, nor does execution. Personally, I think readability does suffer. The wordier it gets, the more I have to think. Why not a simple 'append_sibling'? > -- > Chris Game > > Computers are only human. > > -- Bill Guindon (aka aGorilla)