From: dblack@... Date: 2005-12-08T22:54:27+09:00 Subject: Re: They say I write Ruby like Perl Hi -- On Thu, 8 Dec 2005, Chris Game wrote: > Ryan Leavengood wrote: > >> 1. The general naming convention is lowercase with underscores for >> variables and methods. You have sort of a mix of >> "runitalltogether" variables, i.e. prevsibling, and then the >> CamelCase methods like insertSiblingAfterYou. Those should be >> prev_sibling and insert_sibling_after_you (though that last one >> is a bit too long.) > > Who says? Just a style/convention issue surely. Readability doesn't > suffer, nor does execution. "Just"? :-) You're right, though, in the sense that the parser doesn't enforce traditional style. You can write Ruby that looks like lots of other languages. Then when you go back to those languages, you can write variable names like_this because you now come from Ruby.... Or just break the cycle and use the conventions of whatever language you're using *when* you're using it :-) David -- David A. Black dblack@wobblini.net "Ruby for Rails", forthcoming from Manning Publications, April 2006!