From: Chris Game Date: 2005-12-08T22:27:36+09:00 Subject: Re: They say I write Ruby like Perl Ryan Leavengood wrote: > 1. The general naming convention is lowercase with underscores for > variables and methods. You have sort of a mix of > "runitalltogether" variables, i.e. prevsibling, and then the > CamelCase methods like insertSiblingAfterYou. Those should be > prev_sibling and insert_sibling_after_you (though that last one > is a bit too long.) Who says? Just a style/convention issue surely. Readability doesn't suffer, nor does execution. -- Chris Game Computers are only human.