From: "Marcel Molina Jr." Date: 2005-12-01T04:20:13+09:00 Subject: Re: Dumb question: in documentation, why Object#method, and not Object.method ? On Thu, Dec 01, 2005 at 04:17:30AM +0900, Elf M. Sternberg wrote: > I keep seeing this syntax in documentation: Object#method, but in actual > use sending a message to an object is usually > > object = Object.new > object.method > > Is this just to emphasize that method() operates on an instance of > Object and not the class Object? The # is a naming convention. Class#method means method is an instance method. Class::method means method is a class method. For example, do ri IO.read There is IO::read and IO#read. marcel -- Marcel Molina Jr.