From: Martin DeMello Date: 2005-11-29T22:47:29+09:00 Subject: Re: [BUG] string range membership ara.t.howard@noaa.gov wrote: > > reading this just gave me a new idea: first of all, i think this method > should be a verb so that it implies a loop and test, rather than a simply > test. this is important because the method is, potentally, extremely > expensive. shortening you suggesting then, how about I suggested #generates? elsewhere in the thread, for the same reason - I think it important that the method sounds expensive. Are there any methods currently in the core/stdlib that sound innocuous but have a performance hit under the covers? (#last perhaps?). martin