From: Richard Lionheart Date: 2005-11-20T00:32:22+09:00 Subject: Re: .yml/host: localhost fails in Rails app generation Hi Kev, Thanks for weighing in on my problem. Bottom line, problem solved: I'm running on a WinXP/SP2 platform with MySQL 5.0.15 I Googled as you suggested (which I've been doing, but more vigorously now). Found a solution at http://forums.mysql.com/read.php?45,25582,34721#msg-34721: SET PASSWORD FOR 'root'@'localhost' = OLD_PASSWORD('mypswd');" My yaml settings are: development: adapter: mysql database: depot_dev host: localhost password: mypswd Again, I appreciate you offering the solution of reverting to MySQL 4.x. I tried to avoid that because I wanted to be able to use the newer features, particularly transactions, in the app I intend to build with Rails (after I get done running tutorials). Best wishes, Richard