From: Gregory Brown Date: 2005-11-17T14:31:42+09:00 Subject: Re: Improving code... On 11/17/05, Joe Van Dyk wrote: > I guess I could've done: > return 0.0 if @previous_cpu_time.nil? or @previous_time.nil? > @previous_cpu_time ||= get_process_cpu_time > @previous_time ||= Time.now Yes, I like that.