From: Stuart Date: 2005-11-04T00:02:10+09:00 Subject: FastCGI spawn_fs_process() failed error Hello All. Am running : Windows XPPro, apache2, mysql and rubyonrails. Have struck this problem when putting into place the fastcgi functionality. It comes from the apache error log: [Fri Nov 04 01:45:01 2005] [crit] (OS 3)The system cannot find the path specified. : FastCGI: can't start server "C:/work/websites/cookbook/public/dispatch.fcgi": spawn_fs_process() failed I've scoured the net, and found only that it might have something to do with permissions (which i've set and reset). So i can only think it's something to do with my configuration. This is my .htaccess file, ============ # General Apache options #AddHandler fastcgi-script .fcgi #AddHandler cgi-script .cgi #Options +FollowSymLinks +ExecCGI # If you don't want Rails to look in certain directories, # use the following rewrite rules so that Apache won't rewrite certain requests # # Example: # RewriteCond %{REQUEST_URI} ^/notrails.* # RewriteRule .* - [L] # Redirect all requests not available on the filesystem to Rails # By default the cgi dispatcher is used which is very slow # # For better performance replace the dispatcher with the fastcgi one # # Example: # RewriteRule ^(.*)$ dispatch.fcgi [QSA,L] RewriteEngine On # If your Rails application is accessed via an Alias directive, # then you MUST also set the RewriteBase in this htaccess file. # # Example: # Alias /myrailsapp /path/to/myrailsapp/public # RewriteBase /myrailsapp RewriteRule ^$ index.html [QSA] RewriteRule ^([^.]+)$ $1.html [QSA] RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^(.*)$ /cookbook/dispatch.fcgi [QSA,L] # In case Rails experiences terminal errors # Instead of displaying this message you can supply a file here which will be rendered instead # # Example: # ErrorDocument 500 /500.html ErrorDocument 500 "

Application error

Rails application failed to start properly" ========= These are the relevant changes to the apache config file, ========= LoadModule rewrite_module modules/mod_rewrite.so LoadModule fastcgi_module modules/mod_fastcgi.dll .... Alias /cookbook/ "c:/work/websites/cookbook/public/" AddHandler fastcgi-script .fcgi Options +ExecCGI AllowOverride all Allow from all Order allow,deny FastCgiServer c:/work/websites/cookbook/public/dispatch.fcgi -processes 1