From: Trans Date: 2005-11-02T01:12:08+09:00 Subject: Re: "Readability" inflation Ryan Leavengood wrote: > > I see your point, but: > > require 'enumerator' > > h = House.new > h.enum_for(:each_bathroom).select {|b| ... } > > I *really* don't see how yours is much better. In fact, I'd argue the > enumerator one is better because it is more explicit...anyone who > knows how enumerator works can see what is happening. Only you, me and > the people paying attention to this thread would understand what the > EnumeratorArgs thing was doing. > > But I guess we will just have to agree to disagree, since we are both > dragging this into one of those endless discussions threads that I > dislike so much ;) I see your point too. Enumerator, and things like #every, are starting to come into their own. I wrote EnumerableArgs some time ago when the clearest approach was a beefed up Mixin (we didn't even have #inject yet). Like I said to David easlier, I think we will just have to get used to this new paradigm of intermediate objects acting as "roles". (And I have to admit I've propogated it mayself with the Functor class). So to it's end may I then suggest: h.enumerate(:each_bathroom).select { ... ;) ciao, T.