From: Trans Date: 2005-10-31T02:22:05+09:00 Subject: Re: "Readability" inflation Pit Capitain wrote: > > require "enumerator" > > ObjectSpace.enum_for(:each_object, Class).select { |c| c.name =~ /^S/ } He he! Yep, I'd call that "inflation" alright ;). Better yet, now we've almost come full circle since #enum_for works in essentially the same way as #every ! Don't you just love it David!? ;) Thanks but no thanks. I'll take an Enumerable with args and a elementwise operator over this any day. T.