From: Trans Date: 2005-10-30T05:42:04+09:00 Subject: Re: Malleable Instance Vars Eric Hodel wrote: > On Oct 29, 2005, at 11:57 AM, Trans wrote: > > > Are we ready for > > > > @x = 1 > > > > a = "x" > > > > @{a} #=> 1 > > PHP-style "variable variables" just lead to code that is too clever > for its own good. Using a Hash is a much more readable solution. Perhaps so. And I am presently working on such code. BUt to be honest, I haven't found a more reasonble way to handle it. As it stands I have to do instance_variable_get/set or eval the whoe method def. T.