From: Trans Date: 2005-10-29T02:17:04+09:00 Subject: Re: "Readability" inflation Or 'as'? # A factory method def create_pizza(t=[:pepperoni, :ham] as :toppings, c=[:thin] as :crust_thickness) imaginate(:pizza_factory).make_me(c,t) # [1] end nice short vars for codeing, then # My toppings for today mt=[:ham, :cheese, :pineapple] pizza = create_pizza(mt as :toppings) T.