From: Ernest Ellingson Date: 2005-10-28T03:22:04+09:00 Subject: help with fastcgi I'm really frustrated. Is there a site where an example for httpd.conf using ruby fastcgi? I've looked through all of the threads on fastcgi at ruby-talk. Only found one example for using fastcgi. I'm using Apache 2.x Here is my current httpd.conf relating to fastcgi LoadModule fastcgi_module modules/mod_fastcgi.so FastCgiIpcDir logs/fastcgi ScriptAlias /fcgi-bin/ "/var/www/fcgi/ebw/" AllowOverride All Options None Order allow,deny Allow from all SetHandler fastcgi-script AddHandler fastcgi-script .fcgi when I use my browser to go to http://someDomain/fcgi-bin/login.fcgi I get an internal server error. The error(s) are: [Thu Oct 27 11:02:57 2005] [crit] (13)Permission denied: FastCGI: can't create (dynamic) server "/var/www/fcgi/ebw/login.fcgi": bind() failed [/etc/httpd/logs/fastcgi/dynamic/d2d6483b03d06cd99ec43408de2a0766] [Thu Oct 27 11:03:02 2005] [alert] [client 216.27.164.161] (13)Permission denied: FastCGI: failed to connect to (dynamic) server "/var/www/fcgi/ebw/login.fcgi": something is seriously wrong, any chance the socket/named_pipe directory was removed?, see the FastCgiIpcDir directive [Thu Oct 27 11:03:02 2005] [error] [client 216.27.164.161] FastCGI: incomplete headers (0 bytes) received from server "/var/www/fcgi/ebw/login.fcgi" Any one have a clue as to what I need to do? Ernie