From: Trans Date: 2005-10-23T19:57:01+09:00 Subject: Re: Find the test dir Gavin Sinclair wrote: > The best balance between size and readability is probably the > following: > > find_test_dir > > Of course, the method "find_test_dir" must be implemented somewhere, > but you won't have to read it very often, and you can just use the six > lines you've written above. That' a good point. But my trouble here is that the tests themsselves can get run out of either of two locations: as attached to the bottom of the file they test, which is in lib/ or standalone in test/ dir (same code I just extract it). So there's no convenient place to store this and still be able to require it without the same trouble, AFAIK. > However, I would use the 'pathname' library to clarify some of the > code. Yes, in this case it would be good, but I recently discovered Pathname is terribly slow, so I stopped using it. Thanks, T.