From: Navindra Umanee Date: 2005-09-13T12:32:16+09:00 Subject: Re: confused by nested functions Devin Mullins wrote: > So... The best way to do what you actually want depends on what you > actually want. Thanks for the careful explanation, Devin. > Are you just trying to group a bunch of similar methods > inside a subcomponent of Test, or do you want the Test.boo.moo method to > be dynamically generated based on what Test.boo does? If the latter, I was trying to dynamically generate methods within a namespace -- so essentially the first. For example, I want to generate: Site.tables.table1() Site.tables.table2() Site.pages.page1() Site.pages.page2() Except with better names, of course. :) I guess I should return an Object with the methods I want. Thanks, Navin.