From: "Brian Schröder" Date: 2005-09-05T16:56:27+09:00 Subject: Re: Help me clean up this method On 05/09/05, William James wrote: > > Vincent Foley wrote: > > Hello guys, > > > > I wrote this little method to return the size of a given directory, but > > I think it's very ugly. Could anyone help me clean it up a bit? > > def Dir.size(name) > Dir[ name + "/**/*" ].select{|x| File.file?(x)}.inject(0){|sum,f| > sum + File.size(f) } > end > One more safety addition def Dir.size(name) Dir[ File.join(name, "**/*") ].select{ | f | File.file?(f) }.inject(0){ | sum, f | sum + File.size(f) } end regards, Brian -- http://ruby.brian-schroeder.de/ Stringed instrument chords: http://chordlist.brian-schroeder.de/