From: Vincent Foley Date: 2005-09-05T09:46:26+09:00 Subject: Help me clean up this method Hello guys, I wrote this little method to return the size of a given directory, but I think it's very ugly. Could anyone help me clean it up a bit? def Dir.size(dirname) Dir.chdir(dirname) entries = Dir.entries(".").reject { |x| %w(. ..).include? x } entries.collect! { |filename| File.expand_path(filename) } size = 0 entries.each do |filename| begin if File.file?(filename) size += File.size(filename) rescue 0 else size += Dir.size(filename) end rescue next end end size end Thanks, Vincent.