From: "Florian Groß" Date: 2005-09-03T01:05:38+09:00 Subject: Re: nano & mega Trans wrote: > But also, you do not need to bother with them at all. There are a > couple of options for forgetting about the whole thing. The simplest > is: > > require 'nanosys' > > Then you can use the actual punctuation all you want --and w/o any > special require method: > > require 'nano/array/[]=' But I'd rather see this based on meaningful, easy to understand naming scheme under the hood. Luckily, I have already mapped the special method names. Let me use the look up table from extract.rb: { "+" => "op_plus", "-" => "op_minus", "+@" => "op_plus_self", "-@" => "op_minus_self", "*" => "op_mul", "**" => "op_pow", "/" => "op_div", "%" => "op_mod", "<<" => "op_lshift", ">>" => "op_rshift", "~" => "op_tilde", "<=>" => "op_cmp", "<" => "op_lt", ">" => "op_gt", "==" => "op_equal", "<=" => "op_lt_eq", ">=" => "op_gt_eq", "===" => "op_case_eq", "=~" => "op_apply", "|" => "op_or", "&" => "op_and", "^" => "op_xor", "[]" => "op_fetch", "[]=" => "op_store" } I'd suggest using foo_bang for foo!, foo_p for foo? and foo_setter for foo=.