From: rm_rails@... Date: 2005-08-12T03:04:39+09:00 Subject: Namespace of method arguments (Ruby 2 Idea?) In the Programming Ruby book in the section of namespaces, I see the example: require "trig" require "action" y = Trig.sin(Trig::PI/4) wrongdoing = Action.sin(Action::VERY_BAD) It seems very common to me to use constants from the module as parameters to the module - and rather uncommon to want constants from a different module as a parameer. Is there a reason why a method's arguments can't automatically include the namespace of the module the method came from so I could simply write: y = Trig.sin(PI/4) wrongdoing = Action.sin(VERY_BAD) and have it automatically look in the Trig namespace for the first PI and the Action namespace for VERY_BAD? I think this would make a lot of code that makes heavy use of constants look a lot cleaner; and perhaps encourage people to use constants more often rather than just magic numbers or strings or symbols as arguments.