From: Brock Weaver Date: 2005-08-11T04:37:59+09:00 Subject: Re: new block notation ------=_Part_137_3626752.1123702676293 Content-Type: text/plain; charset=ISO-8859-1 Content-Transfer-Encoding: quoted-printable Content-Disposition: inline I always thought that blocks (aka proc objects) should be in #{}, just like= =20 they are in strings for substitution purposes. That would differentiate {} for grouping lines of code (if, while, etc) and= =20 #{} for grouping a set of code (proc / block / whatever). But that's just m= y=20 $0.02. On 8/10/05, James Edward Gray II wrote: >=20 > On Aug 10, 2005, at 2:09 PM, Eric Mahurin wrote: >=20 > > I'd rather keep the {} > > for blocks/lambdas. But, I don't think we should move the > > ambiguity from blocks vs. hashes (overloading {}) to arrays vs. > > hashes (overloading []). It would be better for hashes to just > > have their own unambiguous syntax. >=20 > We have the current Array[...]/Hash[...] option, which has been > growing on me lately. >=20 > James Edward Gray II >=20 >=20 --=20 Brock Weaver http://www.circaware.com ------=_Part_137_3626752.1123702676293--