From: zedshaw@... Date: 2005-08-10T06:58:58+09:00 Subject: Re: event driven framework for ruby Hey Ezra, this stuff is actually still in my queue of things to get done. The ENOENT is bizarre, but if you have traces for it then send them on. The Apache problem is mostly because I haven't pulled up the courage yet to don the S&M suit and fight the Apache config file monster. :-) Keep bugging me though. > Hey Zed- > I have been using and abusing you scgi server with lightppd > 1.3.15 for the last couple of weeks. It works great so far and > performs very well. The few problems that I have had are as follows: > With lighttpd in production mode it fails with an ENOENT error when > caching is turned on. It seems that it is having problems writing the > cache files. If I restart the same exact app with webrick or plain > lighttpd/fcgi the caching works fine and my permission setup is OK. > Also I have tried to set scgi up with apachge 1.3.33. Everything > seems to work except the round trip back to apache. I mean I can > request different URL's and I can see them get rendered in the > develpment and production logs. But in the browser I just get an > internal server error for any and all pages. > > I really like how easy it was to set up and manage though. Its > great to not have to restart the webserver to restart my app. I'd > love to be able to use this in production but the production caching > issues are the main hold up right now. If you want any stack traces > or log files form some of these errors let me know and I am more than > happy to be a tester and troubleshooter. I would rerally like to see > this project get up and running. > > Thanks for your hard work Zed- > -Ezra Zygmuntowicz > Yakima Herald-Republic > WebMaster > 509-577-7732 > ezra@yakima-herald.com > >