From: Yukihiro Matsumoto Date: 2005-08-06T16:57:20+09:00 Subject: Re: new block notation (was: Re: ruby-dev summary 26468-26661) Hi, In message "Re: new block notation (was: Re: ruby-dev summary 26468-26661)" on Sat, 6 Aug 2005 00:26:17 +0900, Florian Gro� writes: |Why not go with lambda(arg-list) { body } or fun(arg-list) { body } |or def(arg-list) { body } then? I think that the syntax would point |out that this is more than a method that turns a block into an object |and I think that it would be a simple solution. Introducing a new reserved word possibly break existing code. Besides that, there's no good candidate for a new keyword: lambda is too awkward, def is not sufficient since we don't define anything here, and I expect the name fun is used everywhere as local variable names. "->" might appear weird at first. But it doesn't break any code. Pure addition to the current syntax. And it's short enough to encourage functional programming. The last one is my optimistic estimation. There's an opposite possibility that it would be used only to obfuscate code. matz.