From: Stefan Achatz Date: 2005-08-05T01:26:06+09:00 Subject: question about symbol naming convention Hello, I'm glad to get so well founded help here, so here's another beginner question: Trying to make a singleton method private I tried this: class MyClass def MyClass.class_private end def private end private :private private :MyClass::class_private end The nomenclature of the singleton method doesn't make it. What's the right naming? Thanks in advance Stefan Achatz