From: Austin Ziegler Date: 2005-07-29T03:40:49+09:00 Subject: Re: Method Scopes On 7/28/05, Trans wrote: > I would like to see Ruby gain a "scoping feature" (I usually refer to > this as a "namespace", but looking at Matz' discussion of Rite he's > using that to mean something else). This idea is this: Um. Ew? Sorry, but I find that whole concept ("selector namespaces", I think, is the common name for it) code-ugly. To me, "Wizard".format.jumble means that I'm calling the method #format on "Wizard" and then the method #jumble on the result of #format. To have it mean something else randomly is, to say the least, confusing. I'd rather something clearly ugly for this concept, e.g.: "Wizard".format:jumble Or something. Better to be explicit and ugly than hidden and uglier. -austin -- Austin Ziegler * halostatue@gmail.com * Alternate: austin@halostatue.ca