From: Devin Mullins Date: 2005-07-18T08:41:25+09:00 Subject: Re: `not' in parameter lists gwtmp01@mac.com wrote: > I also have a feeling from a human-factors point of > view that punctuation is important to improving the > readability of code. While I think a lisp-like > syntax is immensely powerful from a programatic standpoint > I think that it can be difficult for a human > to read and understand quickly. My feeling is the exact opposite. I think assert foo.respond_to? bar is immensely more readable than. assert(foo.respond_to?(bar)) The punctuation just leads to clutter, and in a block of 100s of other lines like that, the line ends up looking like this to me when I try to skim it: asse oo.respond_to r But I realize that's just personal preference. However, I don't see how a language that allows both syntaxes is going to kill you any more than a language that doesn't place any significance in whitespace. Devin Actually, my favorite syntax would have to be assert (foo.respond_to? bar) Anyways...