From: Daniel Brockman Date: 2005-07-05T15:34:04+09:00 Subject: Re: Observer patch nornagon writes: > What it does is allow you to append a paramter to add_observer. > Observable will then take that paramater and use it instead of the > default :update -- that means you can have one Observable class call > #update_class1 on your class and have the next call #update_class2. I think this is a useful and sensible addition. Whether or not you are observing multiple objects, you want your method to have a more descriptive name than `update'. -- Daniel Brockman