From: Zach Dennis Date: 2005-07-01T02:49:10+09:00 Subject: Re: iterators and block arguments Daniel Brockman wrote: > > ipv4s.collect! { IPv4Address[@] } > publics = ipv4s.select { @.public? } > privates = ipv4s.select { @.private? } > loopbacks = ipv4s.select { @.loopback? } > I disagree. I think this is absolutely horrid looking. And I think that ipv4s.collect! { |ip| IPv4Address[x] } is better. And even if you don't think it adds to readability for single value blocks I like it for things like... server.process( connection ) do |msg, msg_type, socket| # do connection procesing here... end Zach