From: ES Date: 2005-06-06T05:19:24+09:00 Subject: Re: Package, a future replacement for setup.rb and mkmf.rb Le 5/6/2005, "Christian Neukirchen" a �crit: >ES writes: > >> Le 5/6/2005, "Christian Neukirchen" a �crit: >>>ES writes: >>> >>>> Le 4/6/2005, "Christian Neukirchen" a �crit: >> >> Re: naming. Since 'Package', as mentioned, may be ever so slightly >> misleading, perhaps call it 'Kit' or something? If you want to get >> fancier, my pick for my own package manager (whenever I got around >> to it) was 'Oblong' (extra points for the reference). > >While I agree that Package is not a perfect name, Kit isn't better IMO. >It should be a word where everyone can imagine what it is... but there >is no concept of a "kit" in Ruby. > >Still looking for alternatives... Seeing as Aoki-san combined his efforts to setup.rb, 'Install' or 'Installer' would be available. I personally do not think 'Package' is a bad name (because that is what it is), but it may cause confusion since the existing package _managers_ are ambiguously named. Perhaps you should just brave those waters and go with it. A less-bureaucratic and more-dastardly pet name could of course come in handy. That, or a cute logo (which is known to drastically improve the quality of software). >> E >-- >Christian Neukirchen E -- template void quack(duck& d) { d.quack(); }