From: Hidetoshi NAGAI Date: 2005-05-25T20:42:43+09:00 Subject: Re: should change method name "Tk::BWidget::NoteBook#raise"? From: Hidetoshi NAGAI Subject: should change method name "Tk::BWidget::NoteBook#raise"? (Re: Tk::BWidget::NoteBook: retrieve current page) Date: Wed, 25 May 2005 10:28:10 +0900 Message-ID: <20050525.102805.74728618.nagai@ai.kyutech.ac.jp> > I'm very sorry but I forgot method conflict between this and > TkWindow#raise. > I think that the name should be changed. > Of course, it losts compatibility between previous versions > of BWdiget support library. I decide to keep compatibility. Instead of changing the names, add TkWindow#lower_window/raise_window and Tk#lower_window/raise_window to call Tcl/Tk's lower/raise command. -- Hidetoshi NAGAI (nagai@ai.kyutech.ac.jp)