From: Jim Freeze Date: 2005-05-13T03:38:17+09:00 Subject: Re: {} vs begin/end [was Re: object loops and what they return] * Christian Neukirchen [2005-05-13 03:03:54 +0900]: > Then, I'm often in the camp of inline-case users... how about you? The camp I belong to here is what yields the best readability. For example: # for returning short, simple expressions fred = case x when 'y' then true when 'n' then false else raise end # for doing multiple actions - usually no return value case x when 'y' do_long_compute_1 do_long_compute_2 when 'b' do_long_compute_3 do_long_compute_4 else raise end -- Jim Freeze Ruby: I can explain it to ya but I can't understand it fer ya.