From: matz@... (Yukihiro Matsumoto) Date: 2000-02-16T12:33:02+09:00 Subject: [ruby-talk:01419] Re: Yield Hi, In message "[ruby-talk:01415] Re: Yield" on 00/02/15, "Conrad Schneiker" writes: |Could we (the readers of this newsgroup)--in the interest of learn-ability, |teach-ability, comprehensibility, public friendliness, principle of least |surprise, not using Perl-like obscurities (e.g. bless), and everything else |that otherwise makes Ruby great--could we all agree on a better name for the |yield statement that would also be acceptable to Matz, and which could |co-exist for a year or so with a depreciated yield? I always welcome the discussion about better names for `yield' and `iterator?' `yield' is the historical name inherited from CLU, which is the foundation of the concept of iterator. matz.