From: Bill Guindon Date: 2005-05-04T07:53:42+09:00 Subject: Re: [ANN] traits-0.0.0 On 5/3/05, Ara.T.Howard@noaa.gov wrote: > On Wed, 4 May 2005, Joel VanderWerf wrote: > > > Ara.T.Howard@noaa.gov wrote: > >> On Wed, 4 May 2005, Berger, Daniel wrote: > > .. > >>> This doesn't seem to have anything to do with traits: > >>> > >>> http://homepages.ihug.com.au/~naseby/33.html > >>> http://www.iam.unibe.ch/~scg/Archive/Papers/Scha02bTraits.pdf > >> > >> > >> depends on your definition: > > > > http://thad.notagoth.org/cpptraits_intro/ > > > > But that shouldn't cause any confusion to ruby folks... > > hmm. i'll change it back to 'attributes' if people are going to use it but > don't like the name. tom complained that > > class C > attribute 'a' > end > > was slightly verbose and > > class C > class_attribute 'a' > end > > verboser still. > > class C > trait 'a' > end > > sure is nice and short ;-) > > however the former is also quite clear. > > opinions welcome - it's a simple matter to swtich it. I like 'traits', it's a good synonym for attributes, even gets all of it's letters from it. For some strange reason, 'towels' also seems like it might work :) btw, very cool stuff! > cheers. > > -a -- Bill Guindon (aka aGorilla)