From: Ara.T.Howard@... Date: 2005-05-04T03:24:48+09:00 Subject: Re: un_metaclass On Tue, 3 May 2005, Robert Klemme wrote: > Ara.T.Howard wrote: >> thoughts on how to do this >> >> class C >> class << self >> p un_metaclass #=> C >> end >> end >> >> ?? > > I'd prefer to call it #instance 'cause that's what it is. :-) hmmm. ok. any ideas? i'm playing with nesting and ancestors - but no luck. cheers. -a -- =============================================================================== | email :: ara [dot] t [dot] howard [at] noaa [dot] gov | phone :: 303.497.6469 | renunciation is not getting rid of the things of this world, but accepting | that they pass away. --aitken roshi ===============================================================================