From: Trans Date: 2005-04-20T13:29:35+09:00 Subject: Re: Lookup, a.collect{|i|b[i]} I think #[] would have been better if it worked this way and the ary[start, length] notation was left to another method (#slice), or another notation. T.