From: why the lucky stiff Date: 2005-04-18T23:01:16+09:00 Subject: Re: [ANN] Article: Seeing Metaclasses Clearly David A. Black wrote: > The tutorial itself looks good, though the terminology in this area > continues to be a problem. My understanding is that the most general > term is "singleton class", and that "metaclass" is a special term for > singleton class of a Class object. (See Pickaxe, 2nd ed., p. 382.) > So, for example, I would rename your Object#metaclass method > #singleton_class, since it applies to all objects (as per RCR 231). Sure, I'm aware that "virtual class" is the generic term, while Matz has also used "singleton class" and "meta-object" to describe these classes used in tandem with an RObject. I only use the term "metaclass" because it is the term predominantly used in the PickAxe II. While Dave does interchangibly use "virtual class" and "singleton class", the only term he uses to generically refer to the construct is "metaclass". And I really need to be able to wrap these up in a single word, whilst still jiving with the PickAxe. _why