From: Ryan Leavengood Date: 2005-04-18T06:30:40+09:00 Subject: Re: All Quiet on the Western Front: Is Rails overshadowing Ruby? Chad Fowler wrote: > On 4/17/05, Jim Weirich wrote: > >>On Sunday 17 April 2005 02:29 pm, gabriele renzi wrote: >> >>>I think I already said this once long time ago, but I forgot the >>>answer.. why name this method "require_gem" ? It is not the first time >>>people get confused about it, and I think something like "use_gem" or >>>"Gem.load" would be much better, showing that it does not really act >>>like "require" but more like a configuration step. >> >>I agree. I don't know if it is too late to change the name or not. >> > > > Same here. > If everyone agrees, why not "deprecate" (a la Java) require_gem and replace it with a better name. The deprecated version can print out a warning then call the new version. On v1.0 or when RubyGems is distributed with Ruby that deprecated method can be removed (or not...) Ryan