From: Andrew Hunt Date: 2000-02-15T07:38:22-05:00 Subject: [ruby-talk:01379] Re: Yield >From: "Conrad Schneiker" > >With reference to FAQ 3.3, does anyone else find "yield" to be a somewhat >counter-intuitive term? > >I think that (AFIK) either "invoke" or "callwith" (call with) would be a >better statement name. I guess it's used in the sense of "yield a value" from the current iterator context. It'd be clearer if it were something like callBlock or evalBlock or invoke, but these are all longer to type :-) /\ndy