From: Florian Gross Date: 2005-03-21T22:29:49+09:00 Subject: Re: strip and its evil brother strip! Csaba Henk wrote: > Eg., it could be just aliased to Kernel#do. (Don't tell me that "do" also > being a keyword is a problem while we have this also with "class" [that > one annoys me more that this would].) Let's get a visual impression of > it: > > x.do { chop!; strip! } What about the multi-line form? x.do do chop! strip! end So I think that "do" is indeed a bad method name for this... Perhaps we should just go with Kernel#with: with(x) do chop! strip! end But then the question is whether this should return the value of the last statement or its argument...