From: Christian Neukirchen Date: 2005-03-20T19:37:14+09:00 Subject: Re: Paul Graham recommends Ruby Michael Campbell writes: > On Sun, 20 Mar 2005 02:41:54 +0900, Laurent Sansonetti > wrote: >> On Sun, 20 Mar 2005 02:35:50 +0900, Navindra Umanee >> wrote: >> > Christian Neukirchen wrote: >> > > Yeah, but Python 3000 won't have lisp stuff anymore, didn't you read >> > > that? >> > >> > Can you expand on this? >> > >> >> http://www.artima.com/weblogs/viewpost.jsp?thread=98196 >> >> But who cares? :-) > > > From that article: > > "filter(P, S) is almost always written clearer as [x for x in S if P(x)]" And S.find_all { |x| P(x) } is even more readable. :-) (What happened to the S.find_all &:P idea, btw?) > Wow. He and I clearly have different views of "clear". Good for you. :-) -- Christian Neukirchen http://chneukirchen.org