From: Don Owens Date: 2005-03-08T05:45:28+09:00 Subject: Re: Problems connecting MySQL with Ruby The password style has changed in MySQL 4.1. I have seen this error message when trying to access a MySQL 4.1 server with a MySQL 4.0 client. The problem was fixed with the OLD_PASSWORD() function mentioned here: http://dev.mysql.com/doc/mysql/en/old-client.html Don On Tue, 8 Mar 2005 04:34:02 +0900, Marcelo Paniagua wrote: > Hello there! > > I'm using Tomita Masahiro MySQL-Ruby 2.5 Library and MySQL 4.1. When I > try to connect, I receive the following message: > > Client does not support authentication protocol > > Any idea how to correct this? It seems the library works well when it > connects via an anonymous account. > > Thanks! > > Marcelo Paniagua L. > > -- > Este correo esta libre de virus! > > -- Don Owens regexman@gmail.com