From: "David A. Black" Date: 2005-02-22T23:49:49+09:00 Subject: Re: Proposal for nil, 0, and "" in an if statement Hi -- On Tue, 22 Feb 2005, Gavin Kistner wrote: > On Feb 22, 2005, at 7:18 AM, David A. Black wrote: >> It's arguably exactly the opposite of what you'd want -- namely, to >> point up the singularity of 0/""/etc., not their ordinariness. 37534 >> is more vapid than 0 :-) > > Aye, it is arguably so. But I think having a method name of > my_var.is_super_special_because_it_is_so_boring? > might be annoying to type ;) > > >> I'm not sold on this anyway. > > I'm confused, which are you not sold on - the name "vapid" or the concept of > adding a common method across many objects that supports the use cases where > you need to treat their 'empty' values the same? Both, but I meant specifically the concept. David -- David A. Black dblack@wobblini.net