From: Michael Neumann Date: 2005-02-22T22:24:18+09:00 Subject: Re: Proposal for nil, 0, and "" in an if statement David Heinemeier Hansson wrote: >> Here is a proposal for evaluating "", 0, and nil in an if statement: > > > I'd be pretty happy to see that happen. It would make especially Ruby in > view logic a lot easier to deal with. But please please use a different name than "empty?", maybe "nothing?" or "something?" or whatever else. Regards, Michael