From: gabriele renzi Date: 2005-02-17T01:44:51+09:00 Subject: Re: [ANN] FileSystem 0.1.0: Beta for me, Alpha for you Francis Hwang ha scritto: >> second: would'nt something like "FS::Mock" or "test/filesystem" be a >> better name? when I first saw this on rubyforge I thought it was some >> kind of VFS :) > > > I think it's related to how you're supposed to access the lib in your > live code. The name "FileSystem" to me seems less distracting in > production code than something like "FS::Mock" ... It's only being > mocked out in your tests. mh.. but I have the feeling that it /should/ be distracting. Or, better put, that it should make clear that we're working with a test facility. Anyway I understand your reason and you're the author :) > I'm not 100% happy with the current form of access either: Typing > "FileSystem.get_file" when you really just want "File" is sort of > cumbersome. But it just seemed like the least broken thing I could go > forward with while I figured out something else. When we talked about > this at Ruby-NYC a few weeks ago, Patrick was saying I could write a > file to change the definitions of File, FileUtils, Dir, etc. Maybe > that'll be the way to go. > > Anyway, I'm very very open to suggestions regarding the name and/or how > to access it. just a suggestion, maybe you can take a look at how libvfs (on raa) does this.