From: jweirich@... Date: 2001-03-23T09:39:34+09:00 Subject: [ruby-talk:13106] Re: Lapidary questions >>>>> "Nathaniel" == Nathaniel Talbott writes: Nathaniel> [...] It should definitely be either: Nathaniel> assertInstanceOf(object, klass) Nathaniel> assertKindOf(object, klass) Nathaniel> Or: Nathaniel> assertInstanceOf(klass, object) Nathaniel> assertKindOf(klass, object) Nathaniel> [...] What does everyone else think? I vote for the second option, again in the name of consistancy. I do notice that we have ... assertMatch(string, regexp) which is counter to the above. But then RUnit has it backwards too. -- -- Jim Weirich jweirich@one.net http://w3.one.net/~jweirich --------------------------------------------------------------------- "A foolish consistancy is the hobgoblin of little minds." -- Ralph Waldo Emmerson