From: Jim Menard Date: 2001-03-23T03:10:03+09:00 Subject: [ruby-talk:13087] Re: [ANN] Lapidary 0.2.0 "Nathaniel Talbott" writes: > The reason I'm hesitant to use alias_method in this case is because it makes > a copy as opposed to a true alias. I didn't realize that. A re-read of the documentation in the Pickaxe book confirms this. What would it take to do as Nathaniel suggested: rename alias_method to clone_method or copy_method and create a new alias_method that redirects method calls? Jim -- Jim Menard, jimm@io.com, http://www.io.com/~jimm/ "Slideshow ... boring. Loosing ... consciousness ..." -- The Tick