From: Martin DeMello Date: 2005-02-11T00:20:04+09:00 Subject: Re: Class of the Instance [was Re: Building a Better Functor] Gavin Kistner wrote: > > in a common library they re-use frequently? Is there an RCR (or has > there been discussion) about adding a simple method like that to the > language, so you can simply do: It's been discussed several times, but no one has come up with a good name for it yet. (I like proxy_class myself.) martin